using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<amount>\d+)
(?:(?!^$)[\s\S])+
\(medium\)";
string input = @"4211 dogs ate 2 pounds
chris (large)
3454 dogs ate 8 pounds
john (medium)
alex (small)
4211 dogs ate 2 pounds
morgan (small)";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}