import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<amount>\\d+)\n"
+ "(?:(?!^$)[\\s\\S])+\n"
+ "\\(medium\\)";
final String string = "4211 dogs ate 2 pounds\n"
+ " chris (large)\n\n"
+ "3454 dogs ate 8 pounds\n"
+ " john (medium)\n"
+ " alex (small)\n\n"
+ "4211 dogs ate 2 pounds\n"
+ " morgan (small)";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}