re = /^(?P<amount>\d+)
(?:(?!^$)[\s\S])+
\(medium\)/xm
str = '4211 dogs ate 2 pounds
chris (large)
3454 dogs ate 8 pounds
john (medium)
alex (small)
4211 dogs ate 2 pounds
morgan (small)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end