// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xm)^(?P<amount>\d+)
(?:(?!^$)[\s\S])+
\(medium\)").unwrap();
let string = "4211 dogs ate 2 pounds
chris (large)
3454 dogs ate 8 pounds
john (medium)
alex (small)
4211 dogs ate 2 pounds
morgan (small)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}