# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(?P<amount>\d+)
(?:(?!^$)[\s\S])+
\(medium\)
"""
test_str = ("4211 dogs ate 2 pounds\n"
" chris (large)\n\n"
"3454 dogs ate 8 pounds\n"
" john (medium)\n"
" alex (small)\n\n"
"4211 dogs ate 2 pounds\n"
" morgan (small)")
matches = re.finditer(regex, test_str, re.VERBOSE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.