package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<amount>\d+)
(?:(?!^$)[\s\S])+
\(medium\)`)
var str = `4211 dogs ate 2 pounds
chris (large)
3454 dogs ate 8 pounds
john (medium)
alex (small)
4211 dogs ate 2 pounds
morgan (small)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}