#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\[\d+(,\s?\d+|\d*-\d+)*\])"
Local $sString = "[3,33-24,7]" & @CRLF & _
"[3-34]" & @CRLF & _
"[1,3-5]" & @CRLF & _
"[1]" & @CRLF & _
"[1,2]" & @CRLF & _
"[1, 2, 3]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")