$re = '/(\[\d+(,\s?\d+|\d*-\d+)*\])/';
$str = '[3,33-24,7]
[3-34]
[1,3-5]
[1]
[1,2]
[1, 2, 3]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);