using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[\d+(,\s?\d+|\d*-\d+)*\])";
string input = @"[3,33-24,7]
[3-34]
[1,3-5]
[1]
[1,2]
[1, 2, 3]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}