const regex = /(\[\d+(,\s?\d+|\d*-\d+)*\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[\\d+(,\\s?\\d+|\\d*-\\d+)*\\])', 'g')
const str = `[3,33-24,7]
[3-34]
[1,3-5]
[1]
[1,2]
[1, 2, 3]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}