// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\[\d+(,\s?\d+|\d*-\d+)*\])").unwrap();
let string = "[3,33-24,7]
[3-34]
[1,3-5]
[1]
[1,2]
[1, 2, 3]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}