package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[\d+(,\s?\d+|\d*-\d+)*\])`)
var str = `[3,33-24,7]
[3-34]
[1,3-5]
[1]
[1,2]
[1, 2, 3]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}