#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[CEFGV][XYZ][LMNOP][1-9][0-9]$"
Local $sString = "CDEFG" & @CRLF & _
"CXL10" & @CRLF & _
"CDEFGC" & @CRLF & _
"EHIJKL" & @CRLF & _
"FYL12" & @CRLF & _
"FYL123" & @CRLF & _
"FXP12" & @CRLF & _
"GXO99" & @CRLF & _
"gxo99" & @CRLF & _
"GXO9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")