using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[CEFGV][XYZ][LMNOP][1-9][0-9]$";
string input = @"CDEFG
CXL10
CDEFGC
EHIJKL
FYL12
FYL123
FXP12
GXO99
gxo99
GXO9";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}