$re = '/^[CEFGV][XYZ][LMNOP][1-9][0-9]$/m';
$str = 'CDEFG
CXL10
CDEFGC
EHIJKL
FYL12
FYL123
FXP12
GXO99
gxo99
GXO9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);