package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[CEFGV][XYZ][LMNOP][1-9][0-9]$`)
var str = `CDEFG
CXL10
CDEFGC
EHIJKL
FYL12
FYL123
FXP12
GXO99
gxo99
GXO9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}