re = /^[CEFGV][XYZ][LMNOP][1-9][0-9]$/m
str = 'CDEFG
CXL10
CDEFGC
EHIJKL
FYL12
FYL123
FXP12
GXO99
gxo99
GXO9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end