import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[CEFGV][XYZ][LMNOP][1-9][0-9]$";
final String string = "CDEFG\n"
+ "CXL10\n"
+ "CDEFGC\n"
+ "EHIJKL\n"
+ "FYL12\n"
+ "FYL123\n"
+ "FXP12\n"
+ "GXO99\n"
+ "gxo99\n"
+ "GXO9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}