const regex = new RegExp('^[CEFGV][XYZ][LMNOP][1-9][0-9]$', 'gm')
const str = `CDEFG
CXL10
CDEFGC
EHIJKL
FYL12
FYL123
FXP12
GXO99
gxo99
GXO9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}