#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(?'tag'\w+)](?'content'.*?)\[\/\1]"
Local $sString = "[plea]Adsdamksdm fdmakf[/plea]" & @CRLF & _
"[b]Adsdamksdm fdmakf[/b]" & @CRLF & _
"[i]Adsdamksdm fdmakf[/i]" & @CRLF & _
"[v]Adsdamksdm fdmakf[/v]" & @CRLF & _
"[sup]Adsdamksdm fdmakf[/sup]" & @CRLF & _
"[m1]Adsdamksdm fdmakf[/m1]" & @CRLF & _
"[m2]Adsdamksdm fdmakf[/m2]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")