re = /\[(?'tag'\w+)](?'content'.*?)\[\/\1]/m
str = '[plea]Adsdamksdm fdmakf[/plea]
[b]Adsdamksdm fdmakf[/b]
[i]Adsdamksdm fdmakf[/i]
[v]Adsdamksdm fdmakf[/v]
[sup]Adsdamksdm fdmakf[/sup]
[m1]Adsdamksdm fdmakf[/m1]
[m2]Adsdamksdm fdmakf[/m2]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end