import Foundation
let pattern = #"\[(?'tag'\w+)](?'content'.*?)\[\/\1]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[plea]Adsdamksdm fdmakf[/plea]
[b]Adsdamksdm fdmakf[/b]
[i]Adsdamksdm fdmakf[/i]
[v]Adsdamksdm fdmakf[/v]
[sup]Adsdamksdm fdmakf[/sup]
[m1]Adsdamksdm fdmakf[/m1]
[m2]Adsdamksdm fdmakf[/m2]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)