$re = '/\[(?\'tag\'\w+)](?\'content\'.*?)\[\/\1]/m';
$str = '[plea]Adsdamksdm fdmakf[/plea]
[b]Adsdamksdm fdmakf[/b]
[i]Adsdamksdm fdmakf[/i]
[v]Adsdamksdm fdmakf[/v]
[sup]Adsdamksdm fdmakf[/sup]
[m1]Adsdamksdm fdmakf[/m1]
[m2]Adsdamksdm fdmakf[/m2]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);