using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?'tag'\w+)](?'content'.*?)\[\/\1]";
string input = @"[plea]Adsdamksdm fdmakf[/plea]
[b]Adsdamksdm fdmakf[/b]
[i]Adsdamksdm fdmakf[/i]
[v]Adsdamksdm fdmakf[/v]
[sup]Adsdamksdm fdmakf[/sup]
[m1]Adsdamksdm fdmakf[/m1]
[m2]Adsdamksdm fdmakf[/m2]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}