use strict;
my $str = '[plea]Adsdamksdm fdmakf[/plea]
[b]Adsdamksdm fdmakf[/b]
[i]Adsdamksdm fdmakf[/i]
[v]Adsdamksdm fdmakf[/v]
[sup]Adsdamksdm fdmakf[/sup]
[m1]Adsdamksdm fdmakf[/m1]
[m2]Adsdamksdm fdmakf[/m2]';
my $regex = qr/\[(?'tag'\w+)](?'content'.*?)\[\/\1]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}