import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?'tag'\\w+)](?'content'.*?)\\[\\/\\1]";
final String string = "[plea]Adsdamksdm fdmakf[/plea]\n"
+ "[b]Adsdamksdm fdmakf[/b]\n"
+ "[i]Adsdamksdm fdmakf[/i]\n"
+ "[v]Adsdamksdm fdmakf[/v]\n"
+ "[sup]Adsdamksdm fdmakf[/sup]\n"
+ "[m1]Adsdamksdm fdmakf[/m1]\n"
+ "[m2]Adsdamksdm fdmakf[/m2]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}