# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+(\.(?=\d))?\d*//gm;t' <<< "אבג123.אבג
אני קניתי ב2.5~ ש\"ח"