#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d+(\.(?=\d))?\d*"
Local $sString = "אבג123.אבג" & @CRLF & _
"אני קניתי ב2.5~ ש"ח"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)