const regex = /\d+(\.(?=\d))?\d*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(\\.(?=\\d))?\\d*', 'gm')
const str = `אבג123.אבג
אני קניתי ב2.5~ ש"ח`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);