import re
regex = re.compile(r"\d+(\.(?=\d))?\d*", flags=re.MULTILINE)
test_str = ("אבג123.אבג\n"
"אני קניתי ב2.5~ ש\"ח")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)