using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(\.(?=\d))?\d*";
string substitution = @"";
string input = @"אבג123.אבג
אני קניתי ב2.5~ ש""ח";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}