use strict;
my $str = 'אבג123.אבג
אני קניתי ב2.5~ ש"ח';
my $regex = qr/\d+(\.(?=\d))?\d*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";