#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(?!.*nowEXCLUDE.*)Test123"
Local $sString = "abc def ghi jkl mno" & @CRLF & _
"abc def ghi test123 jkl mno" & @CRLF & _
"abc def ghi test123 jkl nowEXCLUDE mno" & @CRLF & _
"abc def ghi jkl nowEXCLUDE mno"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")