import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?!.*nowEXCLUDE.*)Test123";
final String string = "abc def ghi jkl mno\n"
+ "abc def ghi test123 jkl mno\n"
+ "abc def ghi test123 jkl nowEXCLUDE mno\n"
+ "abc def ghi jkl nowEXCLUDE mno";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}