const regex = new RegExp('(?i)(?!.*nowEXCLUDE.*)Test123', 'gm')
const str = `abc def ghi jkl mno
abc def ghi test123 jkl mno
abc def ghi test123 jkl nowEXCLUDE mno
abc def ghi jkl nowEXCLUDE mno`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}