use strict;
my $str = 'abc def ghi jkl mno
abc def ghi test123 jkl mno
abc def ghi test123 jkl nowEXCLUDE mno
abc def ghi jkl nowEXCLUDE mno';
my $regex = qr`(?i)(?!.*nowEXCLUDE.*)Test123`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}