using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?!.*nowEXCLUDE.*)Test123";
string input = @"abc def ghi jkl mno
abc def ghi test123 jkl mno
abc def ghi test123 jkl nowEXCLUDE mno
abc def ghi jkl nowEXCLUDE mno";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}