$re = '`(?i)(?!.*nowEXCLUDE.*)Test123`m';
$str = 'abc def ghi jkl mno
abc def ghi test123 jkl mno
abc def ghi test123 jkl nowEXCLUDE mno
abc def ghi jkl nowEXCLUDE mno';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);