re = /(?i)(?!.*nowEXCLUDE.*)Test123/m
str = 'abc def ghi jkl mno
abc def ghi test123 jkl mno
abc def ghi test123 jkl nowEXCLUDE mno
abc def ghi jkl nowEXCLUDE mno'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end