import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+([\\.-]?\\w+)+@[\\w.-]+([\\.-]?\\w+)(\\.\\w{2,3})+$";
final String string = "babar.ali.shah-512_me.you_ir-getme@gmail-here-there.where_any.resource_avavi.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}