$re = '/^\w+([\.-]?\w+)+@[\w.-]+([\.-]?\w+)(\.\w{2,3})+$/';
$str = 'babar.ali.shah-512_me.you_ir-getme@gmail-here-there.where_any.resource_avavi.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);