const regex = /^\w+([\.-]?\w+)+@[\w.-]+([\.-]?\w+)(\.\w{2,3})+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+([\\.-]?\\w+)+@[\\w.-]+([\\.-]?\\w+)(\\.\\w{2,3})+$', '')
const str = `babar.ali.shah-512_me.you_ir-getme@gmail-here-there.where_any.resource_avavi.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}