// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\w+([\.-]?\w+)+@[\w.-]+([\.-]?\w+)(\.\w{2,3})+$").unwrap();
let string = "babar.ali.shah-512_me.you_ir-getme@gmail-here-there.where_any.resource_avavi.com";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}