import Foundation
let pattern = #"^\w+([\.-]?\w+)+@[\w.-]+([\.-]?\w+)(\.\w{2,3})+$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"babar.ali.shah-512_me.you_ir-getme@gmail-here-there.where_any.resource_avavi.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}