re = /^\w+([\.-]?\w+)+@[\w.-]+([\.-]?\w+)(\.\w{2,3})+$/
str = 'babar.ali.shah-512_me.you_ir-getme@gmail-here-there.where_any.resource_avavi.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end