# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?<!\\)(?:\\\\)*\[(?:\\.|[^\]\[])*)\[/$1\\[/g;t' <<< "^(([^<>()[\]\\.,;:\s@\\"]+(\.[^<>()[\]\\.,;:\s@\\"]+)*)|(\\".+\\"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$"