import re
regex = re.compile(r"((?<!\\)(?:\\\\)*\[(?:\\.|[^\]\[])*)\[")
test_str = "^(([^<>()[\\]\\\\.,;:\\s@\\\"]+(\\.[^<>()[\\]\\\\.,;:\\s@\\\"]+)*)|(\\\".+\\\"))@((\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}])|(([a-zA-Z\\-0-9]+\\.)+[a-zA-Z]{2,}))$"
subst = "$1\\\\["
result = regex.sub(subst, test_str)
if result:
print(result)