import Foundation
let pattern = #"((?<!\\)(?:\\\\)*\[(?:\\.|[^\]\[])*)\["#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"^(([^<>()[\]\\.,;:\s@\"]+(\.[^<>()[\]\\.,;:\s@\"]+)*)|(\".+\"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\\["#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)