$re = '/((?<!\\\\)(?:\\\\\\\\)*\[(?:\\\\.|[^\]\[])*)\[/';
$str = '^(([^<>()[\\]\\\\.,;:\\s@\\"]+(\\.[^<>()[\\]\\\\.,;:\\s@\\"]+)*)|(\\".+\\"))@((\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}])|(([a-zA-Z\\-0-9]+\\.)+[a-zA-Z]{2,}))$';
$subst = "$1\\[";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;