using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<!\\)(?:\\\\)*\[(?:\\.|[^\]\[])*)\[";
string substitution = @"$1\\[";
string input = @"^(([^<>()[\]\\.,;:\s@\""]+(\.[^<>()[\]\\.,;:\s@\""]+)*)|(\"".+\""))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}